Mein neuer (File-)Server

Obwohl ich mir ja schon immer Gedanken um die Sicherheit meiner Daten, und daher regelmäßig Backups mache, stand ich vergangene Woche mal kurzzeitig ganz schön doof da. Der Netzwerk-Adapter auf meinem 6 Monate alten ASUS-Board hatte sich verabschiedet.

 

Einfach so, ohne Vorwarnung. Dumm nur, dass es sich dabei um den Rechner gehandelt hat, den ich zum Geld verdienen brauche. Noch dümmer, dass dies mein einziger Rechner mit S-ATA Anschlüssen ist. Kurzzeitig anderswo die Programme installieren, die Festplatten umbauen und einfach weitermachen war also grundsätzlich keine Option.

Nach diesem Schock war klar, dass sich etwas Grundlegendes ändern musste, um künftig eine schnelle Ausweichmöglichkeit im Falle eines (Total-)Ausfalls zu haben. Da ich ja schon lange mit einem kleinen (File-)Server liebäugle, war mein nächstes Feierabend-Projekt damit besiegelt. Glücklicherweise leben wir ja in einem Zeitalter, in dem selbst ein paar Jahre alte Teile immer noch genug Power haben, um geschwind mal einen kleinen Fileserver aus Alt-Teilen zu assemblieren.

Was war an Teilen vorhanden, was wurde benötigt?

Vorhanden und in Betrieb waren

  • eine Workstation (mein Arbeits- und in dem Fall der Problem-Rechner) (ASUS P7P55D-E LX, Intel Core-i5 760, 8 GB DDRIII-RAM, 64GB Samsung-SSD, ATI Radeon 5770)
  • ein Laptop (HP Compaq 6730s KU447ET#ABD mit 4 GB RAM)
  • ein Wohnzimmer-HTPC (ASUS A8V-VM, Athlon 64 3800+, 3 GB DDRI-RAM, 500 GB P-ATA, Nvidia 8400 GS - mit G98 Chipsatz für den ungetrübten HD-Genuss^^, Hauppauge HVR-4000 DVB-S2)
  • und noch ein Schlafzimmer- HTPC (Fujitsu-Siemens D1761, P4 Northwood 2,8 GHz, 1 GB DDRI-RAM, 120 GB P-ATA, ATI Radeon HD 2600 Pro)

Außerdem ein alter Rechner von meinem Kumpel Petar (an der Stelle nochmals ein herzliches Dankeschön für deine Hardware-Spende, Petar!) mit einem ASRock-Board (K7S41GX), einem Sempron2*00+ und 2x512MB DDRI-RAM, sowie ein MSI-Brett (MS6154 v.2) mit einem 600 MHz Celeron ^^, diverse DDRI-Speicher-Riegel, kleinere und größere P-ATA-Festplatten, ein 145 Watt Netzteil, uswusf.
Zwingend benötigt wurde aber ein PCI-SATA-Controller mit 4 Ports und dem entsprechenden Kabel-/Adapter-Zubehör. Da meine privaten Festplatten inzwischen aus allen Nähten platzen, außerdem noch eine große (1,5 bis 2 TB) S-ATAII-HDD, je nach relativem Preis.

Und los ging's mit dem Zusammenbau

Da ja meine aktiven Rechner alle irgendwie ihre Daseinsberechtigung haben und Petars alter Rechner noch über war, sollte dieser also seinen zweiten Frühling erleben. Das Brett, die CPU und der Speicher waren ok für den geplanten kleinen Server. Um Strom zu sparen flogen das CD- und DVD-Laufwerk, sowie die eingebaute TV-Karte ersatzlos raus. Die PSU musste zugunsten des 145Watt Netzteils Platz machen –  Kurz gerechnet Mainboard ca. 10Watt, CPU 89 Watt TDP, pro Speicher-Riegel 2 bis 3 Watt, pro Platte ca 10 Watt. Macht zusammen hochgerechnet 160 Watt unter Vollast. Da aber kaum alle Platten und die CPU unter Volllast laufen hab ich das jetzt einfach mal mit dem 145Watt Netzteil getestet, da ein 350Watt Netzteil ständig auf Sparflamme laufen, und so ebenfalls viel kostbare Energie verschwenden würde. Bis jetzt gab es aber selbst beim Ein- oder Ausschalten (Stromspitze) mit der 145Watt PSU keinerlei Theater.

Ein Problem war allerdings noch, dass in Petars Case nur wenige interne Einschübe für die Platten zur Verfügung standen, und ich ja beim HDDs Aufrüsten flexibel bleiben wollte. Damit die Festplatten nicht dicht auf dicht aneinander sitzen und sich so unnötig erwärmen, hab ich kurzerhand das Gehäuse mit dem vom Wohnzimmer-HTPC getauscht und vor die Festplatten-Einschübe einen 120 mm Papst-Lüfter geklemmt.

Hardware kaufen - es gibt nur wenig schöneres

Bevor ich mich schließlich auf den Weg zum Hardware-Händler meines Vertrauens machte, wollte ich es erst wissen. Läuft das Ding überhaupt mit den umgebauten Komponenten? Jupp, alles gut! Also, nochmal alles kurz durchgeschaut und folgendes für den bevorstehenden Einkauf notiert:

  • PCI-SATAII-Controller mit 4 Ports
  •  wegen dem besseren Preis-pro-GB-Verhältnis eine 2TB Samsung HDD SATAII
  •  2x Strom Adapter 5,25‘‘ auf 2xSATA
  • 10m LAN-Kabel

Ein SATA Kabel 30cm und zwei Strom-Weichen 5,25‘‘x2 lagen noch in der Ersatzteil-Kiste.

Ein kurzer Blick ins WWW, was kostet denn aktuell noch so ein 4-Port PCI-SATAII-Controller und welche sind überhaupt zu gebrauchen? WOW, knapp 60 Euro für einen annehmbaren Controller! Damit hatte ich offen gesagt nicht gerechnet. Sollte ja kein RAID-Controller werden oder so etwas. Ok, nochmal durchdacht, muss es denn tatsächlich ein SATAII-Controller sein? Eigentlich ja nicht. Die Daten, mit denen ich tagtäglich arbeite bleiben ja auf der Workstation und sollen nur mit den Daten auf dem Fileserver synchronisiert werden. Fürs Arbeiten über das LAN ist mein Netzwerk mit 10/100 MB/s nicht ausgelegt. Und beim Streamen von HD-Material wäre ja auch nicht der SATA-Controller der Flaschenhals. Außerdem wollte ich nicht viel Geld in alte Technik investieren. Der angestrebte Fileserver soll ja so nicht für die Ewigkeit sein und in absehbarer Zukunft gegen eine stromsparendere Alternative mit Gigabit-Anschluss und onboard-SATA ausgetauscht werden.

Die etwas größere Enttäuschung erwartete mich dann im HW-Shop. Kein 4-Port-Controller vorrätig! Nur zweimal der Digitus DS-33101 PCI-Controller mit 2 SATA Ports. Klar, nicht der Hammer-Controller, aber für unter 20 Euro auch nicht die schlechteste Wahl. Zumal es für Digitus-Produkte in der Regel auch passende Treiber gibt.
Die Konkurrenz nebenan hatte zwar den gesuchten 4-Port-Controller – für 20 Euro! Aber von der Marke hatte ich noch nie gehört und erfahrungsgemäß rentiert es sich bei solchen Teilen kaum auf die günstigste Alternative zurückzugreifen. Das bringt nicht selten viel Ärger und einen hohen Zeitaufwand mit sich. Da ich die Zeit nicht gepachtet hab und auch nicht kreuz und quer durch Karlsruhe rauschen wollte, für einen Controller, den ich in einigen Monaten ohnehin wieder rausschmeißen werde, entschloss ich mich kurzerhand für den Digitus in doppelter Ausführung.

Das große Basteln geht weiter

Zu Hause angekommen, die Teile eingebaut, der nächste Schreck. Wenn man das Netzwerk-Kabel in den Server steckt und das andere Ende in die Hand nimmt, spürt man den Stromfluss. :( Nach meinem Netzwerk-Adapter-Defekt an der Workstation konnte/wollte ich den Rechner so keinesfalls ins Netzwerk packen. Also was tun? Das MSI-Board mit dem 600 MHz Celeron verbauen? Nee, geht gar nicht. Einen PCI-Netzwerk-Adapter nachrüsten? Geht auch nicht, da nur zwei PCI-Slots auf dem Mainboard vorhanden sind. Also musste einer der HTPCs dran glauben. Da der Athlon-HTPC im Gegensatz zum P4-HTPC auch 1080p-Material mit hohem Bitstream noch ruckelfrei darstellt, musste also der P4-HTPC dran glauben. Das Board hat auch 3 PCI-Slots, sodass da im Zweifelsfalle auch nochmal was drauf gepackt werden könnte. Gut, nochmal alles auseinander geschraubt, die Gehäuse getauscht und dann der Test – jawoll, läuft!

Im Server werkeln jetzt also:

  • das Fujitsu-Siemens Mainboard D1761
  • ein P4 Northwood mit 2,8 GHz HTT
  • 2x512 MB Buffalo DDRI-RAM
  • die 145 Watt PSU
  • 2x Digitus DS-33101 PCI-SATA-Controller
  • 2x Western Digital Caviar Green SATAII 2TB (WD20EARS)
  • 1x Samsung SpinPoint F4 EcoGreen 2TB (HD204UI)
  • 1x Western Digital 500GB P-ATA
  • 1x Samsung 500GB P-ATA

Endlich, es ging an's Installieren

Nach diesem Erfolgserlebnis stand die letztendliche Entscheidung für, bzw. gegen ein Betriebssystem auf dem Plan. Entweder in einen Microsoft Server (Home, 2003, 2008 RC1) investieren, oder wieder auf Linux setzen? Naja, die Entscheidung war nicht wirklich schwer. Ubuntu Server 10.04 soll es werden. Hab schon eine Weile nicht mehr mit Linux gearbeitet, bin aber früher eigentlich ganz gut mit Kubuntu klargekommen. Außerdem bringt Linux wirklich alles mit, was für den Server benötigt wird und viel zu konfigurieren gibt es bei dem angestrebten Server auch nicht. Allerdings bin ich im Hinblick auf Linux nicht wirklich so fit, als dass ich ganz auf eine Oberfläche hätte verzichten wollen.  Also hab ich letzten Endes doch wieder Kubuntu installiert –wegen dem Langzeit-Support Lucid Lynx 10.04.

Nach der Installation von Kubuntu habe ich erst einmal alle unnützen Programme runter geschmissen und Gparted installiert, um die vorhandenen Platten meinen Bedürfnissen entsprechend zu partitionieren. Dann habe ich einen SSH-, FTP- und Samba-Server installiert. SSH, damit ich den Server über die Konsole (Putty) von Windows aus steuern, und den Bildschirm vom Server abklemmen kann. FTP, für den schnellen Datenaustausch zwischendurch. Und Samba, um auch vom HTPC aus auf die Netzwerk-Freigaben zugreifen zu können. Außerdem habe ich Ethtool installiert, da ich den Server auch via Wake-on-Lan (WOL) wecken möchte. Da der Server ja schon mal da steht, hab ich gleich noch einen LAMP-Server (Linux, Apache, MySQL, PHP, bzw. Pearl) installiert und für den lokalen Gebrauch grundlegend vorkonfiguriert. Allerdings muss ich jetzt erst einmal testen, wie sich das Handling bei der alltäglichen Arbeit gestaltet. Denn auf der Workstation läuft bereits ein fertig konfigurierter XAMPP-/HMailServer auf der SSD. Wenn sich das Datei-Handling nicht als zu umständlich und lahm erweist, werde ich XAMPP/HMail von der Workstation verbannen und via „Eclipse“ und „Filezilla“ extern arbeiten.

Backup, ganz ganz wichtig

Angedacht war ursprünglich auch, den Server auch als Backup-Server laufen zu lassen. Allerdings war mir das aktuell zu zeitintensiv und dann auch zu heikel, mein bewährtes Backup-System zu verwerfen und mich in rsync auf der Konsole einzuarbeiten. Daher hab ich mich jetzt erst mal auf einen einfachen und sicheren Deal eingelassen:
Das Backup auf dem Server selbst geschieht jetzt mit SimpleBackup. Das ist schnell installiert, intuitiv zu bedienen und auch die Wiederherstellung läuft offensichtlich recht zuverlässig. Das habe ich direkt getestet. Ein großer Nachteil von SimpleBackup ist aber aus meiner Sicht, dass es keine Fortschrittsanzeige gibt. Gesichert werden /etc, /usr, /var, sowie das Home-Verzeichnis. Täglich inkrementell und 14-tägig vollständig.
Für das Backup der System-Partition der Workstation greife ich nach wie vor auf Acronis True Image zurück. Dieses Programm verwende ich jetzt schon seit einigen Jahren und wurde noch nie im Stich gelassen! Das System wird täglich inkrementell, wöchentlich differentiell und monatlich vollständig gesichert. Ob das Backup und die anschließende Validierung positiv verlaufen sind, darüber werde ich via Mail informiert.
Die Sicherung der Partition mit den Kundendaten und dem System-Backup der Workstation geschieht halb-automatisch mit AllSync über das Netzwerk. AllSync habe ich dafür so konfiguriert, sodass ich die lokalen Daten auf Knopfdruck mit den Daten auf dem Sever synchronisieren kann. Das hat für mich den Vorteil, dass ich die Daten problemlos auch mehrfach täglich aktualisieren, und im Zweifelsfalle auch von einem anderen Rechner aus darauf zugreifen kann.
Ganz sicher ist damit noch nicht das Ende der Fahnenstange erreicht. Sobald es die Zeit erlaubt, möchte ich schon noch einen Backup-Server einrichten und die Kundendaten zurück in einen verschlüsselten Container packen. Allerdings gestaltet sich die punktuelle Aktualisierung von verschlüsselten Daten nicht ganz so einfach, weswegen ich dies zunächst noch einmal hinten angestellt habe.

Ursprünglich geplant war ebenfalls, die beiden 500 GB IDE-Platten im Raid-1 laufen zu lassen. Diesen Plan hab ich dann aber wieder verworfen, da man so oder so nicht um ein Backup der wichtigsten Daten rumkommt und die Zeit für die Wiederherstellung einer Platte auch nicht zu verachten ist. Dann doch lieber „nur“ ein tägliches Backup anfertigen, das im Zweifelsfalle dann auch schnell wieder hergestellt ist.

Auf ging's ans Server-Fein-Tuning

Während die Installation der Server insgesamt problemlos verlaufen ist, gab es bei der Konfiguration diverse Schwierigkeiten. Die ersten Probleme traten bereits beim Einbinden des Servers ins Netzwerk auf. Normal ist das kein Problem. Der Rechner wird an den Router angeschlossen und erhält via DHCP eine lokale IP-Adresse. DHCP habe ich aber aus Sicherheitsgründen deaktiviert und zwecks Mangel an LAN-Ports läuft hier einen weiterer Netgear-Router als Switch. Da ich dem Server so oder so eine feste IP-Adresse geben wollte, habe ich in der /etc/network/interfaces etwas in der Richtung eingetragen:

iface eth1 inet static
address 192.168.0.123
netmask 255.255.255.0
gateway 192.168.0.1

Wer hier noch den Nameserver eintragen möchte braucht außerdem das Paket resolvconf:

Und dann wiederum in der /etc/network/interfaces den/die DNS-Server eintragen

dns-nameservers 192.168.0.1 10.10.0.10

Bei den Windows-Clients funktioniert die Switch-Funktion des Netgear Routers ohne Probleme. Das Kabel zum ersten Router steckt auch nicht im WAN-Port, sondern in einem der acht LAN-Ports. Der Server wollte sich aber partout am Netgear-Router anmelden. Im Grund ist das nur eine Konfigurations-Sache am Router selbst. Allerdings muss die Konfiguration jedes Mal neu ausgeführt werden, wenn man den Router vom Stromkreis trennt, was bei mir hin und wieder schon mal vorkommt. Und außerdem möchte ich mit Hilfe des zweiten Routers bei Gelegenheit eine so genannte Demilitarized Zone (DMZ) realisieren, um das Netzwerk mit dem Server und der Workstation noch ein bissl besser zu schützen. Daher hab ich mir da jetzt auch erst mal keinen weiteren Konfigurations-„Stress“ angetan, und den Server schließlich direkt am ersten Router angeschlossen.

Server automatisiert Starten und Herunterfahren

Ein weiteres Problem hat sich beim Wake-on-Lan eingestellt. Um den Server übers Netzwerk auf Knopfdruck zu wecken, muss einerseits die Hardware diese Funktion unterstützen und andererseits muss das zu weckende Gerät korrekt konfiguriert werden, um beim Empfang der so genannten Magic Pakete wieder zu erwachen. Klingt alles ganz einfach und logisch. Ist es aber nicht. Kurzum es gibt X verschiedene mögliche Fehlerquellen. Nach einigem herumdoktern hab ich den Versuch den Server via Mausklick zu wecken aufgegeben. Das ist zwar nicht meine Art, einfach die Flinte so ins Korn zu schmeißen, aber in diesem Falle geht es nur darum, dass ich mich morgens nicht vom Arbeitszimmer ins Wohnzimmer bewegen wollte um das Power-Knöpfchen zu drücken. Gemessen daran, welche Aufgaben sonst noch zu bewältigen sind, und in Anbetracht dessen, dass ich morgens ohnehin mehrfach am Server vorbei laufe, wäre es ein Witz gewesen, sich da länger daran aufzuhalten. Persönliches Ehrgefühl hin oder her. :)

Viel wichtiger war es mir dagegen, dass sich der Server nach einer bestimmten Zeitspanne selbst schlafen legt, wenn keine Zugriffe mehr übers Netzwerk stattfinden. Im Grunde keine Mammut-Aufgabe, denn es gibt mehr als genug fertige Scripte im WWW, mit denen sich eine solche Aufgabe bewerkstelligen lässt. Beispielsweise das AutoSuspend Script von Quetschke auf Ubuntuusers.de

http://wiki.ubuntuusers.de/Skripte/AutoSuspend

Btw. Danke an das tolle Ubuntuusers -Forum! Weiter so!

Wie es aber halt bei so Scripts aus dem WWW manchmal ist – auch wenn man sich an die vorgegebenen Anweisungen hält, ein Erfolg ist nicht immer garantiert. Um die Geschichte mit AutoSuspend kurz zu fassen. Der Server hat sich bei mir nicht schlafen gelegt, weil der lokale User angemeldet war. Im Server-Logfile unter /var/log/syslog war dann zu lesen:

… server CRON [****] : (root) CMD (/usr/local/sbin/autosuspend.sh)
… server logger: AutoSuspend: aborted: some users still connected, auto suspend terminated

Der Trick bestand darin, die entsprechende Zeile im Code ausfindig zu machen und den Boolean zu ändern. Aus „false“ mach „true“. Verantwortlich war:

# Read logged users
        USERCOUNT=`who | wc -l`;
        # No Suspend if there are any users logged in
        test $USERCOUNT -gt 0 && { logit "some users still connected, auto suspend terminated"; return 1; }
 

Geändert habe ich das dann in:

# Read logged users
        USERCOUNT=`who | wc -l`;
        # No Suspend if there are any users logged in
        test $USERCOUNT -gt 1 && { logit "some users still connected, auto suspend terminated"; return 1; }
 

Ob das jetzt alles seine Richtigkeit so hat, oder ob das einfach nur QnD ist, weiß ich jetzt ehrlich gesagt nicht genau. Ich weiß nur, dass das Script in der Form jetzt auch auf meinem Sever funktioniert.

Netzwerkordner einbinden, so geht's richtig

Eine letzte Baustelle war schließlich noch die korrekte Einbindung der freigegebenen Server-Partitionen auf den Windows-Clients. Unter Windows 7 geht das eigentlich recht einfach, indem man den Arbeitsplatz öffnet (Computer) und mit der rechten Maustaste auf einen freien Bereich klickt. Dann „Netzwerkadresse hinzufügen“, usw. Etwas umständlicher geht es auch, wenn man unter:

C:\Users\<Name des Benutzers>\AppData\Roaming\Microsoft\Windows\Network Shortcuts

eine entsprechende Verknüpfung anlegt.

Von diesem gängigen Treiben möchte ich hier aber abraten! Ganz einfach aus dem Grund: Wenn man die Netzwerkfreigaben auf diesem Weg einbindet, erhält man bei der Anmeldung am Windows-Client unter Umständen die Fehlermeldung „Es konnten nicht alle Netzlaufwerke wiederhergestellt werden“. Die entsprechend eingebundenen Ordner sind dann auch mit einem roten Kreuz gekennzeichnet. Klickt man auf einen der eingebundenen Ordner, verschwindet das Kreuz und die Inhalte werden dargestellt. Soweit ok.

Bei meinem HTPC hab ich aber beispielsweise das Problem, dass ich diesen nur mit einem Gamepad, bzw. mit einer Fernbedienung steuern möchte, und definitiv nicht erst einmal eine Maus anschließen will, um alle Ordner anzuklicken.

Die Lösung ist eigentlich recht einfach. Man braucht eine entsprechende Batch-Datei, die beim Starten des Windows-Clients ausgeführt wird. Man kann den entsprechenden Aufruf einfach mal in der Kommandozeile testen. Den eingebundenen Netzwerk-Ordner erstmal trennen, und dann unter Start/Ausführen -> cmd eingeben. Der Befehl lautet dann:

„net use“, dann der gewünschte Laufwerksbuchstabe, der genaue Netzwerk-Pfad, das Passwort, der Benutzer, und schließlich ob die Verbindung dauerhaft sein soll. Also bspw.

net use a: \\ip-adresse\frei-gegebener-ordner Passwort /user:Benutzername /persistent:no

Bei den Namen für die freigegebenen Ordner immer darauf achten, dass es keine Leerzeichen gibt. Also „Daten1“, statt „Daten 1“.

Wenn die Einbindung auf diesem Wege funktioniert, dann öffnet man einfach den Texteditor seiner Wahl, und trägt alle freigegebenen Ordner nacheinander ein. Da es beim Hochfahren von Windows und dem Laden der Netzwerktreiber zu Verzögerungen kommen kann, ist es ratsam ganz am Anfang der Batch-Datei einen, oder sogar mehrere Pings auszuführen. Das sieht bei mir dann in etwa so aus:

ping 192.168.0.123 -n x
net use a: \\192.168.0.123\Data1 passwort /user:dasbinich /persistent:no
net use b: \\192.168.0.123\Data2 passwort /user:dasbinich /persistent:no
net use i: \\192.168.0.123\Audio passwort /user:dasbinich /persistent:no
net use j: \\192.168.0.123\Visu1 passwort /user:dasbinich /persistent:no
net use k: \\192.168.0.123\Visu2 passwort /user:dasbinich /persistent:no
net use l: \\192.168.0.123\Visu3 passwort /user:dasbinich /persistent:no

Wenn alles eingetragen wurde, speichert man das Ganze als txt-File, wobei man die Endung .txt nach dem Speichern durch .bat ersetzen muss. Dann noch eine Verknüpfung in den Autostart-Ordner legen, und nochmal neu starten.

72 Stunden und 135 Euro nach Projekt-Beginn

Für mich hieß es dann eigentlich nur noch die Tastatur, die Maus und den Monitor vom Server zu trennen, und die Kiste möglichst weit hinten in eine Ecke zu packen, wo halt noch genug Luft hinkommt. Im Moment frage ich mich, ob ich mich nochmal drauf und dran machen soll, die CPU zu undervolten. Das würde den Energie-Verbrauch nochmal senken und könnte die Lebenszeit der mittlerweile knapp 8 Jahre alten CPU nochmal etwas verlängern.

Naja, wer weiß, vielleicht ist das ja das nächste Projekt, über das ich hier berichten werde.

Share this

Wow, ein wirklich klasse

Wow, ein wirklich klasse und sehr detaillierter Bericht über deinen Server. Hut ab. Bekommt man richtig lust auf´s Basteln. Muss übrigens sagen, dass ich mit meinem NAS von dir super zufrieden bin. Der Datentransfer und die Zugriffe sind eingerichtet und es macht richtig Spass von einer zentralen Stelle auf sämtliche Dateien von jedem Ort des Hauses zugreifen zu können. Wahnsinn.

Aber so langsam kribbelt es immer mehr in den Fingern, was den Bau eines Mini ITX HTPC´s auf VDR Basis zu basteln. Domi, wir müssen reden :-)

Haha, Maik. Das war doch

Haha, Maik. Das war doch auch Sinn und Zweck der Übung. Lust machen aufs Basteln! :o) Wenn du soweit bist mit dem HTPC, ich bin auch bereit.

Freut mich zu hören, dass du mit deiner NAS-Lösung zufrienden bist. Für eure Bedürfnisse im Heimnetzwerk hätte alles andere auch gar keinen Sinn ergeben. Im Gegensatz zu dem File-Server hier habt ihr jetzt so eine platz- und energiesparende, preiswerte, und vor allem leise Lösung. Mein Server macht schon ordentlich radau und was er so an Strom zieht will ich grad gar nicht wissen.

Was ist mit dem zwischenzeitigen Ruckeln, wenn die Eltern unten HDs schauen? Weg? Und gibt es eine Zeitverzögerung, wenn ihr Filme anlaufen lasst?
Bei mir geht das unter Umständen einige Sekunden bis das Bild da ist, wobei der Ton von Anfang an durchläuft. Außerdem "hängt" es manchmal kurzzeitig, wenn ich im Film vor- oder zurückspringe. Fängt sich dann aber auch gleich wieder.

Hey Domi, also die

Hey Domi,

also die Festplatten laufen nach Zugriff über´s Netzwerk, superschnell an. Bei größeren Dateien ruckelt es halt alleweil. Aber nur beim Streaming über die Dreambox. Der HTPC im Wohnzimmer hat damit garkeine Probleme.

Nachher Fussball??? Freu